Common Terms and Methods

Segments in AutoPIPE

The model is divided into Segments which is helpful to identify and select different parts of the model. Typically, a new segment means a new branch. Segments have a direction – learn this. It is critical for insertion of points, and for interpretation of output results. Also, using View/Segment menu, users can turn on and off segments for viewing and making changes to the model. Using the Select Segment icon, users can select by segment.

Segment modeling tips to minimize the total number of segments and facilitate making modifications later.

*An header, where possible should be coded as one segment.*

All branches should be separate unique continuous segments and avoid coding the same segment through the header to the branch or vice-versa.

Unique segments should be coded from Tee to Tee or Equipment anchor to Tee or Anchor to Anchor or Manifold header Start to End.

Avoid junction points i.e. 2 connecting segments in a straight pipe run.
Pipe Identifiers

A segment can be made up of multiple pipe identifiers where a pipe identifier contains all the properties of the pipe i.e. pipe size, schedule, insulation, material etc. Therefore to change a property e.g. pipe materials use Modify/properties of pipe identifier. To define completely different properties of a section of the model e.g. new pipe size, use Select /Range (selected points = highlighted RED) then use Modify/pipe properties over range, an existing pipe identifier can be selected from the drop-down list or ENTER a new 8 character name.

Units

Units for every applicable field are displayed in bottom right hand corner of screen when the cursor is in the field.

Inserting an Intermediate Single or Multiple Points between Existing Points

Click once on the point either before or after where you want to insert. Then click “Pipe Run” icon.

**Note:** The Pipe run icon has a field for “Generate Points“ (see below). Type the number of intermediate points and length (a default length will be shown e.g. 1 point = midpoint between 2 existing run points) between them if more than 1.

**Note:** You can add a single point or multiple points either After (After is default) or Before an existing point. Before and After refers to the segment direction which the model is built. **Hint:** Very useful for quickly creating equally spanned support points on a pipe rack.
Changing Offset Lengths

If you check box “Apply offset to all following points”, it will do exactly that e.g. if change the offset from 3 to 10 then all downstream points move the same change in offset = 7. If you don’t check box this option, it “slides” the point without changing the overall length of the system. Try clicking on a run point and changing offsets both ways to see for yourself. See screen below:

This function is also available from the right click menu in the Point Input grid.

Flanges

In AutoPIPE, Flanges are a 1 point element with no length i.e. considers only the flange weight and type of weld connection to pipe for SIF calculation. Yes, assuming flange stiffness is same as the pipe is technically incorrect because a flange is more rigid than pipe, but no, it doesn’t affect analysis results to any significant extent in most cases. Cases you may wish to model the rigid length of the flange would be in a short stiff piping arrangement or close to equipment like pumps. If you want to input flange length, insert a pipe run and insert flanges at the mating point then select this short length and use **Insert > Rigid options over Range** (Include Weight = off, Include Thermal Expansion = off...pipe will be shown purple). AutoPIPE’s flange screen has option to do ANSI flange loading check.
3x Diameter or Larger Sweep Elbows

AutoPIPE’s Bend Point dialogue screen (above example) has a Bend radius field which defaults to Long radius with pull down option for short radius. You can either select short radius or, for a large sweep elbow, click once on the Bend radius field and type the actual radius (units are in bottom right hand corner of screen).

Zoom

The fastest way to zoom is to create a box window by holding down left mouse key and dragging over the area to be zoomed, then right mouse click once to zoom. This is way faster than having to click on the zoom icon each time. **Note:** Use dynamic zoom by right mouse click once to change the cursor from Pan (hand) to Zoom (magnifying glass) to Rotate. *Also use the mouse scroll wheel for fast dynamic zoom on the mouse cursor.*

**Note:** Also Zoom topic above. Like CAD - 4 or 2 or 1 viewport can have different zoom settings which are saved when the model is closed. So when model is opened again - screen settings are at the same location as when the session was closed.

Guide Support

A guide support in AutoPIPE is different than Caesar’s guide element – it’s equal to Caesar’s 2 supports (guide and Y stop). In AutoPIPE, a guide supports the pipe in the vertical and lateral directions but not axial. Users can input gaps to remove vertical support or other directions if required. A guide support in AutoPIPE is always normal to the local pipe axis, so if the pipe is rotated the guide stays normal to the pipe which is very useful also when guides on skewed pipe. **Note:** Large gap will not display the support symbol in that direction for convenience.

Navigating

For navigating on the graphics model i.e. go from point to point, *use mouse click or left/right arrow keys to navigate along the pipe.* Arrow keys are often faster than mouse clicking. For dialogue screens, use tab key, Shift Tab to go back, or mouse click to go to desired field. To close a dialogue, it’s usually faster to press the Enter key instead of mouse clicking the OK box.

To Check Model Connectivity

Use the left and right keyboard arrow keys to move the cursor along the pipe from point to point. If the cursor stops but looks like more piping then use the up/down arrow keys to ‘jump’ to the next segment (segment name changes at bottom right corner) while the point name stays the same. If the cursor does not jump to the next segment then this point is a ‘free’ end point and disconnected from the remaining model. *At a tee point use the up/down arrow keys to ‘jump’ to the branch or header segment – the tee arrows will highlight red to indicate whether the cursor is on the branch or header side.*
**Note:** A tee point may have 2 or 3 segments intersecting it.

**Hint:** Use AutoPIPE’s V8i new Connectivity Checker, which will scan the model and check for points within a node tolerance that are not connected along a segment.

---

**Selection Sets**

Not available in other Pipe Stress programs, just as with Microsoft Word or other windows applications, users first ‘select’ what needs to be modified, then they modify it – same with AutoPIPE. With AutoPIPE, there a number of ways to select ranges: click on one end, then hold shift key down and click on the other end. Also, there is an icon to select by segment and users can go under Select menu to select by component if desired (for example, select only flange points, or flex joints). In addition, the user can select single points using the Ctrl key. Selection sets can also be used for inserting or deleting across ranges of points or components.

**Examples:** Paste across ranges, insert or delete supports across range, insert User SIF for all bends or Tees, Insert soil or distributed loads across range or modify temperature & pressure for range. Selection sets are very important in using AutoPIPE. *If you don’t understand selection sets, you’re not efficiently using AutoPIPE.*
Hold CTRL Key to Select Multiple Points

Insert > Guides Placed at all Selected Points
Operating Load Combinations

If you want AutoPIPE to automatically create operating load combinations for support loads and displacements, go to Tools/Combinations and click the option **Add default NonCode Combination**, as shown below: Combinations for load cases are also created by default but can be unselected for printing.
Inserting Valves, Reducers or other Components after Elbow or Tee

AutoPIPE does not allow users to insert a component directly after an elbow without first inputting a run point from the tangent intersection point to the end of the elbow. This means that there will be 2 points, a bend point and a run point, at the same location. This is not so unreasonable since AutoPIPE’s elbow dimension is based on the tangent intersection point. For inserting valves and other components directly after a tee, AutoPIPE requires that the user first input a run of pipe after the tee before inserting the component to model the leg of the tee.

Wind Loads

When specifying elevations wind load profile, remember to check ground elevation is correctly defined on the main Wind screen. This applies also to wind loadings to ASCE-7 and UBC. Opening older models a warning message “negative elevations found” may indicate an incorrect wind loading across this model.

View/Show/Pipe Menu & Toolbar

AutoPIPE enables users to graphically view the model by Pipe diameter, schedule, wall thickness, pipe material, Pipe identifier (also includes Boolean logic e.g. view all 6” and schedule 40 pipe in the model. Check this feature out as is very useful for checking and verifying input.

Point Properties/Global Coordinates Icon/Button (F3 key)

Try it, it’s useful to check pipe properties, temperatures/pressures, and global coordinates on a given point. By clicking on different points, this screen stays up, and users can quickly check their model.

Three Way Valves

Inputting three way valves in AutoPIPE is a bit convoluted at this time. AutoPIPE does not allow users to branch from a valve, so here is what you have to do: Divide the valve into 3 pieces, length and weight divided, and input them as separate valves, but put very short dummy runs of rigid pipe (select ‘rigid’ as pipe data identifier) in between the valves and at the branch. Convert the run points to a Tee using the “convert run to tee” icon/button.

See below what it should look like:
Nonlinear Load Sequencing

Whenever you have a nonlinear analysis with gaps and/or friction, the sequence in which loads are analyzed affect analysis results because the “initial state” position is dependent on which loads were analyzed before. For example, Earthquake or Wind loads analyzed after T1 (wind hitting the operating position of the piping) may calculate different support loads than earthquake or wind loads calculated just after GR (wind hitting the ambient position of piping). When doing a nonlinear analysis, first select **Loads > Static Analysis Sets** and check the option “Non-Linear”.

*Also refer to Load_Sequencing.pdf in the AutoPIPE XM program folder*

To define all non-linear options, modify the analysis set, and check the option “Gaps/Friction/Soil”, Click OK and the next screen appears, select the operating case to use for occasional loads like wind or seismic.

For more complicated load sequences uncheck the “Use Default Sequence” box to modify the Load sequence and Enter or click OK. See following screen shot:
USEFUL PRODUCTIVITY FEATURES THAT NEW USERS OFTEN OVERLOOK

Powerful Result Filtering

This is a very powerful capability for isolating only the results you need. Example, using Result >Filter criteria/Support, you can generate a report which only shows that supports which exceed 7,000 lb. Vertical load, or have pipe deflections at the support point which exceed 5” in the X, 1” in the Y, or 4” in the Z. Result filters not only save lots of time, they prevent errors from slipping through the cracks. Result filters can be combined with graphical select (Example: output report contains only the points in the graphically selected range which exceed user defined deflection criteria).

You can also use the Result >Filter criteria to satisfy a flange analysis, often engineers want to evaluate highly loaded flanges e.g. flanges with stress > 7000 psi. Define the filter criteria as: Select Result/Filter criteria/Code stress, code stress option = checked, greater than 7000. Click OK will highlight all points meeting this criterion. Clear the selection set then Select/ flanges then Result output report, check both options “Limit results to highlighted points” & Apply Filter Criteria (Result >Filter) to create a flange report with stresses > 7000psi.

Familiarize yourself with this useful capability

Edit > Move Stretch – Pipe Racks

Users can select one point, or a range of points, and “stretch” the point or range of points, automatically changing cut lengths of the connections. Also, the Edit >Move Stretch can “slide” a component or group of components with or without changing the overall length of the system. This capability is very useful for “sliding” supports, valves, control station assemblies, expansion joint assemblies, frame assemblies from one position to another. Another good use is for pipe rack piping,
copy/paste one line and offset from existing line then any changes in any direction can be made using **Edit > Move /Stretch** command.

Copy the segment then paste using the offset options shown below either from origin or from any other selected frame or piping point in the model.
Place cursor at B06 and insert a bend

**Bend Point**

- Add point [B]efore/[A]fter: After
- Point: B06
- Name of point: B14
- Radius: Long
- Bend type: Elbow
- Offset from which point (O=Origin): B06
- Length: 2.000
- Offsets - DX: 0.000
- DY: 2
- DZ: 0.000
- [Apply offset to all following points]:
- Pipe data identifier: STD
- Midpoint: Percentage around the bend:
- Flexibility Factor: Automatic

[OK] [Cancel] [Help]
Select range below & move DX = -2
Select Range below and move DZ = -2

Select Range below and DY = -2. It is done 2 parallel pipelines routed using copy/paste and move commands
Insert a segment offset from any point or Origin, useful for building new branch pipeline or another pipe on a rack.

Insert > Segment, DX = 2, B00 offset from point A13
Insert Run DX = 4

Insert > Run, 3 points @ 4’ spacing
Most Useful Hot Keys

**Note** that AutoPIPE’s menus have one letter underlined. The Insert menu, for example is probably, the most useful. By typing I then R you insert a run, I B = insert bend, I V = insert valve. After inputting your data, it’s always faster press the Enter key instead of clicking OK. Another useful hot key is Ctrl T or click on the toolbar icon to graphically view temperatures.

Min/Max for Support Loads and Deflections

Go to Tools >User Defined Comb. /NonCode menu. Give the combination name as e.g. Max Comb Combination method is **9 Sign Max** (which ignores the sign of loads and deflections). Next, select the Case/comb for GR and your operating combinations, ignoring the theoretical loads of T1, W1, etc. Now check your output results for Support report, Deflections, or Restraint summary to see the new Max Comb results that you have created. See example below:

**Hint:** Sign Max and Res Max (Resultant Maximum) are 2 common methods to evaluating maximums from other load cases or combinations. Other methods used are Min and Max.
Save and Reuse Common Piping and Support Configurations between Jobs

Use AutoPIPE’s graphical copy/paste capabilities to store commonly used pipe configurations (pump stations for different services, for example, or common vessel configurations) or complicated expansion joints or commonly used support structures using AutoPIPE’s beam/frame elements. Just copy & paste from one job to another.

**Note:** The models must be in the same directory. Open 2 side by side sessions of AutoPIPE then copy/paste from one model to the other OR into the same model.

This is one of the most powerful features in AutoPIPE

![Graphical Multiple Copy/Paste](image)

Define all the pipe identifiers for a project for the different pipe sizes, insulation, corrosion and material in one template model then use this to start a new model using already the already pre-defined pipe properties. Do not have to redefine these pipe properties again saving time and mistakes.
Using Copy/paste + Move command are powerful tools to template and recreate similar identical plant configurations from one project to the next.

**Modifying a Point Where There Are Multiple Components**

Even a support point has both a run point and a support at the same point. First, left mouse click once on the point you want to modify to make it the ‘active’ point. Next, right mouse click on the toolbar icon button of the component you wish to modify. For example, if you want to modify run point location to “slide” the support location, right mouse click over pipe run toolbar icon to change offsets. To modify a support, right mouse click over the toolbar support icon. Alternatively, to modify supports, double-click on the end of the support symbol itself on the graphics model.

*Note:* If 2 or more supports at one point then if it is difficult to double click on the support then click on the point then use Ctrl + Q (clear all selected points), use modify/support and a drop down list will appear with all the supports at the current point. Alternatively modify the support using the support grid. Similarly to delete a component, click on it to highlight RED then press the Delete key or click on the delete toolbar icon.

**User Combinations as a Template for the next model**

User code or non-code combinations created in the program can be used as a template for other models with the same analyzed load cases. Copy the CMB file to the directory containing the new model and rename it to new *model name*.cmb, when the new model is analyzed the previously defined combinations will be available.

**Input Grids**

Very powerful for reviewing the data and making global changes to the input grid e.g. select multiple cells or complete column to change support friction, enter the value = 0.3 then press CTRL + Enter. Notice grayed out cells are not updated.
**Note:** All Grids are dynamically synchronized bi-directionally with the graphic plot. Select a cell or group of cells and make a change – immediately see the change on the plot and vice versa. If click on a component on the plot this will place the arrow cursor on the row in the current grid.

To make global changes on cells with drop-down lists e.g. support type first select all cells then hold CTRL key and click on any of the cells to select the new item then CTRL + Enter to apply to all selected cells.

**Note:** Multiple cells can be changed across different columns provided it is 'like-data' e.g. all support gaps or all offsets.

**Hint:** To try to different support configurations e.g. try 3 springs instead of Vstop’s as shown below. Select the supports in the Grid then hold the CTRL key down and select spring from the drop down list for one cell in the range then press Enter.

*Like Excel select columns then right click to hide or unhide them*
**Sorting**: Double click the header of any column (cursor shown as downward arrow); to sort the data into logical groups e.g. support types. To restore the default sort order double click on the top leftmost cell.

**Hint**: This is very useful to find mistakes in the data e.g. incorrect support type, friction or gaps.

**Modify**: To modify a component data through the dialog – double-click the row for the component.

**Delete**: To delete a component – click on the row and press the Delete key or click on the Delete toolbar icon

**Selecting**: Selecting cells or rows in any grid will Select /highlight those components on the graphic plot which can provide an accurate method of selecting.
components compared to graphical ‘point and click’ method. This also enables multiple random selections made by first holding the CTRL key down and mouse selecting the rows or cells – same as MS Excel.

**Zooming the Grid:** Any grid can be zoomed In or Out by holding the CTRL key and pushing the mouse scroll wheel forward or backward.

**Mouse Right-Click menu:** Useful functions like undo/red, selecting All/Clear, copy/paste and custom printing available.

**Other productive features of Excel-like Grids**

Printing any grid to one page, other options to customize the header and footer with model and company information.

**New Input Grid features**

- Option to not show Zeros = easier to review input data
- Option to show column Headings + Hide/Unhide
- Slide point or component along pipe OR move downstream piping
- Print all data on one Page
To Modify piping only, first turn off the Frame members using View > Hide Components (select Beam).

Alternatively make the beams transparent (However while good for viewing the beams can still accidentally be selected when modifying the piping)
Avoid time in finding and scrolling through lots of data for large models. Use the View > Segment command (Pre V8i) to select and isolate a few segments to work on, troubleshoot and/or display results for.

**Note:** View > Segments or View > Show all components will display all segments again
Only segment B data shown in the GRID which matches the plotted segment B only.
Isolate and Show On-screen results for Segment B only

V8i Edition or later use new toolbar icons or Segment Grid

**Improved Segment Viewing**

Isolate Segments for editing and viewing results for Large Models

Select Segment / Hide Selected Segments / Hide Unselect Segments / Show all Segments

New 1-click Toolbar icons. Select then Hide Selected or Unselected Segments
Use Tee Grid as SIF Calculator

What Tee types will give a satisfactory stress? – Quick check

Change the Tee Type = Code Tee
SIF automatically re-calculated

Soil Identifiers are Templates from Model to Model

Like Pipe Identifiers, Soil Identifiers can be a template and used over and over again in the model without having to re-define the properties

New Soil and Soil ID Grid – Check & make global changes to Soil Properties quickly

Drag ‘Soil ID’ to Apply Soil to new Range or change soil spacing
Distance Calculator as a Productive Tool

Use the graphical distance calculator to check distances and clearances between pipe to pipe or pipe to structure.
Tools > Distance or Select the distance icon on the View toolbar. Point and Click the TO and the From point. Don’t have to enter the point name.

Hint: The DX, DY, or DZ offsets can be read or copy/pasted to Excel or text file.
Reference Point to Evaluate Equipment Loads

Insert > Xtra data > Reference Node

Works in either Global or local coordinate systems. So anytime the nozzle is at a skewed angle to the vessel and the allowable loads at the nozzle are given relative to the nozzle axis then use the local coordinate axis system.

Hint: Useful for evaluating in-line pump nozzles and manufacturer stated limits on vessels or equipment.
Graphics
Difficulty viewing color plots? Change contrasting legend colors on-the-fly

Graphics
Want to scale the size of supports or other components for preferred viewing?

0 means scaled to the pipe size
Enter 0.5 for Solid Anchor scale factor
Show Realistic support arrangements to Clients, Contractors or CAD Designers

Graphics

Realistic Support Symbols

- Single Hangers
- Rod Hanger
- 2 Springs or 2 Constant Hangers
- Base Spring
- Bi-directional V-Stop
- Base Support Shoe

Graphics

Quickly Check Tee Types on the Plot

View/Show Tee
Switch between Single / Double or Quad viewports to easily work in a view which is convenient then switch back to single view. Viewports are available for editing the model AND viewing results e.g. code stresses in plan, iso and elevation views as below

**Graphics**

**Viewports are saved switching between Single/Double/Quad but also after closing then reopening the model**
Existing Caesar Users

Caesar users are used to looking at the model, then reading and entering the point name. In AutoPIPE like CAD use point and click, point names are automatically taken care of.

Productivity Example – Add a Support

<table>
<thead>
<tr>
<th>AutoPIPE</th>
<th>Caesar</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Click on the Support Point</td>
<td>1. Look at the Graphic Plot &amp; Read Point Name</td>
</tr>
<tr>
<td>2. Select Support Type (Friction &amp; Gaps)</td>
<td>2. Goto the Data Sheet</td>
</tr>
<tr>
<td></td>
<td>3. Click on the Restraint Option</td>
</tr>
<tr>
<td></td>
<td>4. Enter the Point Name</td>
</tr>
<tr>
<td></td>
<td>5. Select Support Type (Friction &amp; Gaps)</td>
</tr>
</tbody>
</table>

- 2 way gaps permitted all supports
- Guide – Both Horiz + Vertical
- Only 1 gap permitted
- 2 supports required for Guide + Y

Pipe Stress Work involves lots of Iterations

99 levels of Undo / Redo are available at all times in AutoPIPE such that different support configurations can be tried and if stresses or equipment loads are worse then can easily revert back to some previous state. But in Caesar undo/redo is always lost when exit the INPUT module.

Alphanumeric node numbering by segments – easy to identify which nodes relate to which parts / line numbers of the model
**Caesar**

- NOT like MS Excel – No Multiple Copy/Paste, No Column Sort
- Only Modify ONE cell at a time
- ‘Ripple Effect’ can cause a lot of checking and rework

<table>
<thead>
<tr>
<th>FROM</th>
<th>TO</th>
<th>DX FL.</th>
<th>DY FL.</th>
<th>DZ FL.</th>
<th>PIPE OD in.</th>
<th>PIPE WALL in.</th>
<th>+MILL TOL %</th>
<th>-MILL TOL %</th>
<th>RIS Thk in.</th>
<th>Corrosion in.</th>
<th>T1 Deg F</th>
<th>T2 Deg F</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>10</td>
<td>20</td>
<td>0.5000</td>
<td>10</td>
<td>20.0000</td>
<td>1.5000</td>
<td>12.5000</td>
<td>12.5000</td>
<td>1.0000</td>
<td>0.2500</td>
<td>200.0000</td>
<td>575.0000</td>
</tr>
<tr>
<td>2</td>
<td>20</td>
<td>30</td>
<td>3.1875</td>
<td>0.0000</td>
<td>4.0000</td>
<td>5.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
</tr>
<tr>
<td>3</td>
<td>30</td>
<td>40</td>
<td>0.5000</td>
<td>0.0000</td>
<td>2.5417</td>
<td>10.0833</td>
<td>12.5000</td>
<td>12.5000</td>
<td>1.0000</td>
<td>0.2500</td>
<td>200.0000</td>
<td>575.0000</td>
</tr>
<tr>
<td>4</td>
<td>40</td>
<td>50</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
</tr>
<tr>
<td>5</td>
<td>50</td>
<td>60</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
</tr>
<tr>
<td>6</td>
<td>60</td>
<td>70</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
</tr>
<tr>
<td>7</td>
<td>70</td>
<td>80</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
</tr>
<tr>
<td>8</td>
<td>80</td>
<td>90</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
</tr>
<tr>
<td>9</td>
<td>90</td>
<td>100</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
</tr>
<tr>
<td>10</td>
<td>100</td>
<td>110</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
<td>0.0000</td>
</tr>
</tbody>
</table>

**AutoPIPE**

**Key Benefits vs Caesar**

- Bi-directionally synchronized with the plot
- Make global changes across multiple cells of like data
- Sort any column into logical data groups
- Select multiple ranges of components with graphical highlight
- Real time graphical plot update with multi-level undo/redo
- Customized printing
- Behaves like MS Excel unlike Caesar List spreadsheet

**Review Component Data**
VCR buttons allow fast navigation to sorted multiple maximum stresses across multiple stress categories including maximum sustained stress, thermal range and all occasional stress combinations which Caesar does not calculate automatically.
**AutoPIPE Result Grids** provide powerful filtering and sorting of displacements, forces, support loads and stresses.
Jacketed Piping – Use transparent setting for pipe.

Easily create the Jacket by using the graphical Select and copy / paste functions. Select the range of carrier pipe including valves, flanges, reducers etc and pasting then connecting back onto itself... covered in advanced training

Common Caesar modeling techniques and equivalent in AutoPIPE

Make Global Changes e.g. changing coefficient of frictions for pipe supports, global changes to pressures, temperatures, materials, etc

Caesar

Use List spreadsheet
E.g. change temperature from 482 F to 555F throughout the model
Change RED value e.g. 482 to 555 and 'Ripples' down to next RED value. Difficult to identify which part(s) of the model has changed. Need to keep switching on the color temperature plot. Maybe other parts of model to change to 555 also, need to find them.

Change e.g. 482 to 555. Cannot see this change in legend nor on the color temperature plot unless reset the plot.
AutoPIPE

Make Global changes to pressure, temperature. Option A is best for performing global changes across the whole model. Option C allows best method to check all values being changed point by point.

**Option A** – Modify > Operating Load by Value, Select the existing temperature and enter the replacement value. This will replace all temperatures = 482 with 555 in the whole model
Option B – Select the range in the model to change temperature, select Modify > Pressure & Temperature, enter new temperature = 555 (shown in blue to indicate which values have changed then click OK.)

Color plot and legend value immediately updated with the
**Option C - Use Input Grids**

Suggest Select View > Show > Temperature (case 1) first to see color temperature plot.
Select the cells with this temperature, (first double click Case 1 Temp column to sort it) – then enter new value 555 and press CTRL + Enter. (Drag down or copy down commands using right click menu, are also available for making global changes like Excel. Notice the selected cells immediately highlight RED on the plot to see which parts of the model are to be changed.)
**Caesar**

Change friction values one by one.

- Support Grid – double click column to sort data, select cells, Enter new value and press CTRL + Enter. One CTRL + Z step will undo the complete change.
- Alternatively select the complete column, Hold the CTRL key down and select one cell, enter new value e.g. 0.4 and press CTRL + Enter.

**AutoPIPE**

Note: Double click cell 1 here to restore sort order.

- Support Grid – double click column to sort data, select cells, Enter new value and press CTRL + Enter. One CTRL + Z step will undo the complete change.
- Alternatively select the complete column, Hold the CTRL key down and select one cell, enter new value e.g. 0.4 and press CTRL + Enter.
Update Material Libraries

Recommend do not use the Tools > Library function to update libraries
Material libraries are organised into 2 tables, table 1 with generic materials e.g. CS, HC etc which only have physical properties (no allowable stress). Table 2 has Code Specification materials e.g. A106-B, A312-TP316 which have temperature vs. allowable stress data

**Note**: Version 9.0 more exotic alloy steels like duplex stainless, Haynes 556, incoloy 825, copper C12200-B88 and Hastelloy C22 for B31.3 library.

**Option A**
Provide source data to Bentley including temperature vs. expansion & modulus, density, poisons ratio, plus temperature vs. allowable stress (sometimes also yield stress – required by some codes like B31.3). Bentley will create a custom library but not nuclear QA tested.

**Option B**
Request the library source for the piping code year and instructions from Bentley, enter own data and recompile the library.

FRP /GRP /Plastic materials – refer to Modeling FRP and Plastic Piping_.doc
Following FRP library is available for use typically with B31.3

<table>
<thead>
<tr>
<th>Standard Material Name</th>
<th>Description</th>
<th>Thermal Expansion Coefficient (α)</th>
<th>Young's Modulus (E)</th>
</tr>
</thead>
<tbody>
<tr>
<td>BS2000</td>
<td>BS 2000</td>
<td></td>
<td></td>
</tr>
<tr>
<td>BS2400</td>
<td>BS 2400</td>
<td></td>
<td></td>
</tr>
<tr>
<td>BS3000A-5M</td>
<td>BS 3000A 5&quot;</td>
<td></td>
<td></td>
</tr>
<tr>
<td>BS3000A-8G</td>
<td>BS 3000A 8&quot;</td>
<td></td>
<td></td>
</tr>
<tr>
<td>BS3200</td>
<td>BS 3200</td>
<td></td>
<td></td>
</tr>
<tr>
<td>BS3400</td>
<td>BS 3400</td>
<td></td>
<td></td>
</tr>
<tr>
<td>BS4000</td>
<td>BS 4000</td>
<td></td>
<td></td>
</tr>
<tr>
<td>BS5000</td>
<td>BS 5000</td>
<td></td>
<td></td>
</tr>
<tr>
<td>BS5020</td>
<td>BS 5020</td>
<td></td>
<td></td>
</tr>
<tr>
<td>BS7000</td>
<td>BS 7000</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CL-2030S</td>
<td>FIBERCAST CL-2030 3/4&quot;</td>
<td>Fibercast</td>
<td></td>
</tr>
<tr>
<td>CL-2030L</td>
<td>FIBERCAST CL-2030 1/2&quot;</td>
<td>Fibercast</td>
<td></td>
</tr>
<tr>
<td>III-VE</td>
<td>FIBERCAST III-VE</td>
<td>Fibercast</td>
<td></td>
</tr>
<tr>
<td>III-EP</td>
<td>FIBERCAST III-EP</td>
<td>Fibercast</td>
<td></td>
</tr>
<tr>
<td>SARPLAST</td>
<td>SARPLAST</td>
<td>Sarcastic</td>
<td>Sarcastic</td>
</tr>
<tr>
<td>CONLEY</td>
<td>CONLEY</td>
<td>Corley</td>
<td>Corley</td>
</tr>
<tr>
<td>RPSA-150</td>
<td>RPSA-150</td>
<td>Reinforced Plastic Systems</td>
<td>Reinforced Plastic Systems</td>
</tr>
<tr>
<td>RPSF-150</td>
<td>RPSF-150</td>
<td></td>
<td></td>
</tr>
<tr>
<td>PVC1120</td>
<td>HARVEL PVC 1120</td>
<td>Harvel</td>
<td></td>
</tr>
<tr>
<td>PVC2110</td>
<td>HARVEL PVC 2110</td>
<td>Harvel</td>
<td></td>
</tr>
<tr>
<td>CPVC4120</td>
<td>HARVEL CPVC 4120</td>
<td>Harvel</td>
<td></td>
</tr>
</tbody>
</table>
Pipe Properties or Pipe Identifiers – templates for complete project

Materials are selected for each pipe identifier defined in the model.

Pipe Identifiers can be defined at the beginning of the project or job and used as templates for each model i.e. the pipe properties including materials do not have to be re-defined over and over again. Pick and choose which pipe identifiers to be applied over any selected range of pipes.
Setting the Global Coordinates for Start of the Model

Similarly for disconnected piping systems (segments) set the starting coordinates. Note: A new segment can be inserted (Insert > Segment) and enter the Offset point e.g. B10 (not O for origin) and corresponding offsets. So the new segment will be inserted offset from a known point instead of the origin (O).

Alternatively, Modify > point (at first point in the model) and enter starting offsets from the Origin (0,0,0).

In the point grid, go to top and enter the offsets or global coordinates of the first point in the model.
Defining Wind, Wave and Earthquake Loads

Go to the Load menu to define them.

Note: Up to 10 seismic loads are available useful for evaluating +X, -X, +Z, -Z as a minimum for non-linear cases. (Only 3 uniform loads available in Caesar). Similarly up to 10 wind cases available in the one static analysis.
**Building Structures**

**Insert > Section Properties**, select the steel sections from the libraries to be used in the model... called Section ID’s  
**Insert > Frame**, to insert a new beam into the model. Note: Beam assemblies can be copy/pasted into the model (connected or unconnected)...useful for independent pipe rack portal frames.

---

[Image of AutoPIPE software interface showing the Beam Section Properties and Frame options]
Renumbering of Point Names

Renumber either by Segment or across the complete model using following menu (Toolbar icon also available). Recommend use renumbering when lots of intermediate points are inserted into the model so numbering becomes sequential again.

Select either alphanumeric or numeric numbering. Alphanumeric is automatically by segment name e.g. A00, A01 etc for segment A. This can be easier to identify different parts of the model later.

If a point name is manually entered e.g. PS01 then this name is NOT renumbered unless this option is checked.
C-Node or Connecting Nodes in Caesar

These are connecting nodes (not physical nodes) for following purposes:

Report loads at a vessel or equipment nozzle: Equivalent in AutoPIPE to a Reference Point (Insert > xtra data > Reference point). This is a better solution allowing either loads and allowable limits (e.g. from manufacturer) to be reported in a global or local direction. Local is very useful for skewed piping. A reference point can be assigned to any point in the model.

Connect a support from one node to another. **In AutoPIPE, simply type in the connection node in the support dialog.**
Define a displacement at a support

In AutoPIPE simply assign a displacement at the support for any load case, GR, T1, T2, E1, etc during modelling. Caesar has limitation of defining only 9 displacements which have to be combined in post processing to specific load cases. Insert > Xtra data > imposed support displacement. These can be applied also to anchors but only act in the direction of the restraint.